Degraded BTC Performance

Incident Report for Coins.co.th

Resolved

This incident has been resolved.
Posted Feb 09, 2023 - 07:57 GMT+07:00

Investigating

We are currently investigating this issue.
Posted Feb 08, 2023 - 12:58 GMT+07:00