Degraded BTC Performance
Incident Report for Coins.co.th
Resolved
This incident has been resolved.
Posted Dec 08, 2022 - 18:24 GMT+07:00
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2022 - 17:35 GMT+07:00
Investigating
Outgoing and Incoming BTC Transactions are currently unavailable. Our team is currently investigating the issue.
Posted Dec 08, 2022 - 11:07 GMT+07:00